Increased error rates on calls
Incident Report for Talkdesk
Resolved
The earlier incident has been resolved. We've monitored our service since resolving this and everything is back to normal.

If you need any help, please reach out to us at support@talkdesk.com
Posted Jan 19, 2021 - 19:24 UTC
Monitoring
We have resolved the earlier errors affecting some calls. We will continue to monitor the situation.

If you are still experiencing problems, please reach out to us at support@talkdesk.com
Posted Jan 19, 2021 - 18:57 UTC
Update
We are still observing some errors for a subset of calls. We are working continuously to resolve.
Posted Jan 19, 2021 - 18:32 UTC
Update
We are still observing errors for a subset of calls. Our engineering team is still all hands on deck to resolve the issue.
Posted Jan 19, 2021 - 17:49 UTC
Identified
We have identified an issue that may lead to increased error rates on calls. Our engineering team is working to mitigate the issue.
Posted Jan 19, 2021 - 17:17 UTC
This incident affected: Telephony (Inbound, Outbound) and Agent Experience & Routing (Call Flows & Routing).