Live dashboard and Integrations degraded performance in US region

Incident Report for Talkdesk

Resolved

This incident has been resolved.
Posted Sep 03, 2025 - 18:47 UTC

Update

We are seeing full recovery across all affected services, including Live. We will continue to monitor this behavior to ensure a smooth recovery.
Posted Sep 03, 2025 - 18:41 UTC

Monitoring

We are seeing ongoing recovery across all affected services. Live is still experiencing residual latency in some widgets that we expect to recover shortly. We are still monitoring and will provide an update in the next 1 hour.
Posted Sep 03, 2025 - 18:34 UTC

Update

Lag is not increasing at this time and data freshness of Live might take up to 2 minutes to update. We are monitoring and working on further mitigation measures. We will provide an update in the next two hours or sooner.
Advance Dialer and Talkdesk for Service Cloud Voice has been recovered and are now operational.
Posted Sep 03, 2025 - 18:17 UTC

Update

Lag is not increasing at this time and data freshness of Live might take up to 30 seconds to update. We are monitoring and working on further mitigation measures. We will provide an update in the next two hours or sooner.
A subset of calls on Advance Dialer and Service Cloud Voice might being impacted at the moment.
Posted Sep 03, 2025 - 17:49 UTC

Update

Mitigation steps are still in progress. Users in the US region may still be experiencing a delay of 30s updating widgets in Live Dashboards and Integrations. We are seeing that his value is being maintained and we will work to reduce it to nominal values.
We will provide an update in next hour or sooner.
Posted Sep 03, 2025 - 16:42 UTC

Identified

We are seeing increased lag on Live and Integrations, with delays of up to 30 seconds. We are currently investigating.
Posted Sep 03, 2025 - 16:21 UTC
This incident affected: US (mytalkdesk.com) (Talkdesk for Salesforce (Talkdesk Integrations), Talkdesk Zendesk Connector (Talkdesk Integrations), Talkdesk Live™ Dashboard (Talkdesk Platform)).