Conversations UI might not update to reflect call status in US Region

Incident Report for Talkdesk

Resolved

Mitigation measures have improved the experience. f you are currently facing an issue, refreshing Talkdesk Workspace should mitigate the behaviour.
Posted Oct 19, 2025 - 03:26 UTC

Update

We are still working with our partner to ensure this transient issues are resolved. If you are currently facing an issue, refreshing Talkdesk Workspace should mitigate the behaviour.
Posted Oct 19, 2025 - 02:54 UTC

Monitoring

We are seeing improvements on status coherence for Talkdesk Agents. We are monitoring this sistuation and will keep this page up to date.
Posted Oct 19, 2025 - 02:27 UTC

Update

We are still seeing transient failures on updating agent call status.
Posted Oct 19, 2025 - 02:05 UTC

Identified

We have a new reoccurrence of an issue with our Messaging provider. Our team is applying mitigation measures.
Posted Oct 19, 2025 - 01:40 UTC
This incident affected: US (mytalkdesk.com) (Talkdesk Conversations (Talkdesk Omnichannel Engagement)).