Outbound calls degraded performance in US Region
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Jun 22, 2023 - 16:35 UTC
Monitoring
Mitigation measures are in place and we are seeing system recovery. We are currently monitoring the system. We will provide an update in 30 min or sooner.
Posted Jun 22, 2023 - 16:34 UTC
Update
Mitigation measures are in progress and we are currently seeing recovery. Inbound calls are working as expected. We will provide an update within 15 minutes.
Posted Jun 22, 2023 - 16:29 UTC
Identified
We are currently experiencing an issue with Outbound calls in the US regional deployment. Outbound calls are successful, but only the mute and calls controls are available. Inbound calls are working as expected. We will provide an update within 15 minutes.
Posted Jun 22, 2023 - 16:13 UTC
This incident affected: Americas (US) (Outbound (Telephony)).