Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 07, 2025 - 08:30 UTC
Scheduled
Talkdesk will be conducting maintenance work on our US-EAST-1 Service Border Control Region. This SBC cluster is equipped with a robust redundancy mechanism. This system is designed to ensure that a call will try both of our regional SBCs before failing, We will be running our maintenance on an SBC at the time ensuring that there is no expected impact, however inbound and outbound calls might have to try both SBCs before connecting to the agent increasing slightly the time to connect. During the maintenance window we will be closely monitoring service to ensure no further impact.
Posted Dec 03, 2025 - 08:31 UTC
This scheduled maintenance affected: US (mytalkdesk.com) (Inbound Calls (Talkdesk Voice), Outbound Calls (Talkdesk Voice), Talkdesk BYOC (Bring Your Own Carrier) (Talkdesk Voice)).