Problems logging in and answering calls
Incident Report for Talkdesk
Resolved
The issue is now resolved. Please reach out if you need any additional help.
Posted 9 months ago. Mar 02, 2018 - 09:39 PST
Monitoring
We have seen the issues subside and service return to normal. Our engineering and support teams will continue to monitor our services. Please reach out to us at support@talkdesk.com if you are still having trouble.
Posted 9 months ago. Mar 02, 2018 - 09:02 PST
Update
Customers have reported issues receiving calls, changing status, and logging in. Our engineering team has identified the issue with our telecom provider and is working with them to solve it with the highest priority.

Update: We have received an update from our provider that they are seeing recovery from impacted services. We are continuing to address this issue with priority.
Posted 9 months ago. Mar 02, 2018 - 08:36 PST
Identified
Customers have reported issues receiving calls, changing status, and logging in. Our engineering team has identified the issue with our telecom provider and is working with them to solve it with the highest priority.
Posted 9 months ago. Mar 02, 2018 - 08:29 PST