Conversations UI might not update to reflect call status in US Region

Incident Report for Talkdesk

Resolved

This incident has been recovery
Posted Oct 19, 2025 - 01:11 UTC

Monitoring

We are seeing recovery in regards to the UI updating call status. We will keep monitoring this situation.
Posted Oct 19, 2025 - 01:06 UTC

Identified

This is related to our Messaging Provider and we are seeing recovery, after mitigation measures were applied.
Posted Oct 19, 2025 - 00:56 UTC

Investigating

We are working on mitigation measures to try and solve this issue.
Posted Oct 19, 2025 - 00:40 UTC
This incident affected: US (mytalkdesk.com) (Talkdesk Conversations (Talkdesk Omnichannel Engagement)).