Live contacts latency in US region
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Aug 25, 2023 - 17:51 UTC
Monitoring
We have implemented mitigation measures and are seeing recovery. We will update you in 30 minutes or as soon as we are fully recovered.
Posted Aug 25, 2023 - 17:32 UTC
Investigating
We are currently investigating an issue impacting Live data freshness, there is latency in all Contact related data in the US region. This is not impacting any calls or call routing functionality, only the Live data. Our engineering team is currently applying mitigation measures. We will provide an update within 30 minutes.
Posted Aug 25, 2023 - 17:24 UTC
This incident affected: Americas (US) (Live Reporting (Reporting & Analytics)).