Issues logging into Callbar
Incident Report for Talkdesk
Resolved
The earlier incident has been resolved. We've been monitoring services since resolving this and everything is back to normal.

If you need any help reach out to us at support@talkdesk.com
Posted 5 months ago. Apr 24, 2018 - 13:58 PDT
Monitoring
We have now resolved the issue affecting logging into Callbar and we're continuing to monitor the situation. You should now be able to use Talkdesk again normally.

If you are still experiencing problems please reach out to us at support@talkdesk.com and we will be happy to help.
Posted 5 months ago. Apr 24, 2018 - 13:36 PDT
Investigating
We are aware of a problem right now affecting some customers ability to log in to Callbar. Our engineering team are investigating the root cause. We will provide another update ASAP.
Posted 5 months ago. Apr 24, 2018 - 13:33 PDT