Degraded performance impacting Agent Dashboard
Incident Report for Talkdesk
Resolved
Systems continue to operate normally, and consider this incident as closed.
Posted May 30, 2020 - 08:02 PDT
Monitoring
Between 11:00 - 12:30 UTC there were intermittent errors that impacted some functionality in the Agent Dashboard. Call controls, submitting dispositions, loading certain areas (contacts, call history), and integrations were impacted.

Between 13:55 - 14:05 UTC a small amount of errors returned, and this time caused an intermittent problem for any users attempting to log in and log out of the Agent Dashboard during that time.
To note: making and receiving call functionality wasn’t impacted. Agents using the Callbar also did not experience these issues.

The issues have been mitigated and we are continuing to monitor the situation.
Posted May 30, 2020 - 07:30 PDT
This incident affected: Integrations (Pop & Automated Task Execution), Apps (Agent Dashboard), and Voice (Call Controls).