Call History and Voicemail not available
Incident Report for Talkdesk
Resolved
This incident has been resolved. Please contact support@talkdesk.com if you need any assistance.
Posted 23 days ago. Oct 20, 2018 - 18:55 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 23 days ago. Oct 20, 2018 - 18:32 PDT
Identified
Customers are reporting difficulties in accessing Call History, Recent Calls and Voicemails. The issue has been identified and we are implementing a fix.
Posted 23 days ago. Oct 20, 2018 - 18:30 PDT
This incident affected: Voice - Call Recordings & Voicemail.