Service Degradation
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Aug 25, 2022 - 16:36 UTC
Monitoring
Mitigation measures are currently in progress and we are seeing improvements, a subset of users are experiencing degraded performance affecting Routing, Call flows, Agent Dashboard Actions, and Login. We will provide an update in 15 minutes or sooner.
Posted Aug 25, 2022 - 16:21 UTC
Identified
Mitigation measures are currently in progress and we are seeing improvements, a subset of users are experiencing degraded performance affecting Routing, Call flows, Agent Dashboard Actions, and Login. We will provide an update in 15 minutes or sooner.
Posted Aug 25, 2022 - 16:05 UTC
Update
We are currently investigating degraded performance on Routing, Call flows, Agent Dashboard Actions, and Login affecting a subset of customers. We will provide an update in 15 minutes or sooner.
Posted Aug 25, 2022 - 15:54 UTC
Investigating
We are currently investigating degraded performance affecting Routing and Call flows. We will provide an update in 15 minutes or sooner.
Posted Aug 25, 2022 - 15:39 UTC
This incident affected: Agent Experience & Routing (Agent Dashboard, Call Flows & Routing), Platform (Talkdesk ID Login), Apps (Agent Workspace, Callbar), and Telephony (Inbound, Outbound).