Our mitigation measures have been successful and we are seeing recovery in all our regions. We will keep monitoring the situation.
Posted Feb 10, 2026 - 19:55 UTC
Update
Mitigation measures are successful in our EU Region, recovery is still on going in our US region however failures are transient at this point. We will update as soon as our US region is fully recovered.
Posted Feb 10, 2026 - 19:36 UTC
Identified
Mitigation measures are being deployed on both sites and we are seeing recovery from these measures however transient issues might still occur we will keep this post up to date until full resolution.
Posted Feb 10, 2026 - 19:30 UTC
Investigating
We are observing degradation to Inbound and Outbound call functionality in US and EU region causing errors or impact on audio for a subset of calls, there is not widespread impact at the moment and our team is already applying mitigation measures. We will update this post shortly.
Posted Feb 10, 2026 - 19:14 UTC
This incident affected: US (mytalkdesk.com) (Inbound Calls (Talkdesk Voice), Outbound Calls (Talkdesk Voice)) and Europe (mytalkdesk.eu) (Inbound Calls (Talkdesk Voice), Outbound Calls (Talkdesk Voice)).