Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 22, 2025 - 08:30 UTC
Scheduled
Talkdesk will be performing a platform maintenance on Sunday, 22nd of June, 2025, between 08:30 UTC - 10:30 UTC (02:30 - 04:30 PDT).
During this maintenance window, infrastructure enhancements will be made to increase platform resilience.
During this maintenance window: • Explore API will be unavailable. • All POST and GET requests for report submission and retrieval will return HTTP 502 or 503 errors. • Previously submitted reports that do not complete before the start of maintenance will fail and will require manual resubmission after the upgrade is complete.
We recommend that users avoid initiating long-running report requests close to the start of the maintenance window to minimize disruption.
This page will be updated throughout the maintenance.
Thank you for your understanding.
Posted Jun 18, 2025 - 09:09 UTC
This scheduled maintenance affected: Americas (US) (Talkdesk Explore™ Reporting (Talkdesk Platform)), Americas (Canada) (Talkdesk Explore™ Reporting (Talkdesk Platform)), and Europe (Germany) (Talkdesk Explore™ Reporting (Talkdesk Platform)).