Outbound calls degraded performance for UK phone numbers

Incident Report for Talkdesk

Resolved

This incident has been resolved.
Posted Jul 25, 2025 - 22:44 UTC

Monitoring

We are observing recovery from call failures affecting a subset of phone numbers in the United Kingdom. We will continue to monitor the situation to ensure full service recovery. We will provide an update as soon as possible.
Posted Jul 25, 2025 - 21:01 UTC

Update

Our carrier partners are still working with the local carrier for mitigation measures for the outbound failures to a subset of numbers in the United Kingdom. We will update as soon as we receive more information.
Posted Jul 25, 2025 - 19:50 UTC

Update

Our carrier partners are still working with the local carrier for mitigation measures for the outbound failures to a subset of numbers in the United Kingdom. We will update as soon as we receive more information.
Posted Jul 25, 2025 - 18:58 UTC

Update

Our carrier partners are still working with the local carrier for mitigation measures for the outbound failures to a subset of numbers in the United Kingdom. We will update as soon as we receive more information.
Posted Jul 25, 2025 - 17:14 UTC

Update

Our carrier partners are still working with the local carrier for mitigation measures for the outbound failures to a subset of numbers in the United Kingdom. We will update as soon as we receive more information.
Posted Jul 25, 2025 - 16:10 UTC

Update

Our carrier partners are still working with the local carrier for mitigation measures for the outbound failures to a subset of numbers in the United Kingdom. We will update as soon as we receive more information.
Posted Jul 25, 2025 - 14:04 UTC

Update

Our carrier partners are still working with the local carrier for mitigation measures for the outbound failures to a subset of numbers in the United Kingdom. We will update as soon as we receive more information.
Posted Jul 25, 2025 - 12:15 UTC

Identified

Outbound calls are intermittently failing, this behaviour is only affecting calling UK phone numbers. Our carrier partners have confirmed that it is a UK local issue. We will provide an update as soon as possible.
Posted Jul 25, 2025 - 10:50 UTC
This incident affected: Americas (US) (Outbound Calls (Talkdesk Voice)), Americas (Canada) (Outbound Calls (Talkdesk Voice)), Europe (Germany) (Outbound Calls (Talkdesk Voice)), and APAC (Australia) (Outbound Calls (Talkdesk Voice)).