Call Recordings are Delayed in EU Region

Incident Report for Talkdesk

Resolved

Call recordings as been fully restored and service is back to normal. Thank you for bearing with us.
Posted Mar 22, 2025 - 14:18 UTC

Monitoring

Mitigation measures were put in place and we are serving the the recordings after the call is finished. All delayed recordings are also delivered as well.
Posted Mar 22, 2025 - 14:14 UTC

Update

We are continuing to apply mitigation measures to reduce the delay in serving the call recordings
Posted Mar 22, 2025 - 13:34 UTC

Identified

We have identified the root cause and are applying mitigation measures
Posted Mar 22, 2025 - 12:53 UTC

Investigating

We are currently investigating a delay in call recordings in the EU Region. We will keep this incident up to date.
Posted Mar 22, 2025 - 12:37 UTC
This incident affected: Europe (Germany) (Talkdesk Call Recording™ (Talkdesk Workforce Engagement)).