Mitigation measures have concluded and services are back to normal. Freshness of data in Explore and Live is also recovered
Posted Sep 02, 2025 - 22:50 UTC
Update
Mitigation steps have been applied, and the system is still recovering. The system is currently recovering previous events, a subset of users in the US region may still be experiencing a delay in updating widgets in Live Dashboards. We will provide an update in 1h:30 minutes or sooner.
Posted Sep 02, 2025 - 22:00 UTC
Update
Mitigation steps have been applied, and the system is still recovering. The system is currently recovering previous events, a subset of users in the US region may still be experiencing a delay in updating widgets in Live Dashboards. We will provide an update in 1h:30 minutes or sooner.
Posted Sep 02, 2025 - 20:28 UTC
Update
Mitigation steps have been applied, and the system is still recovering. The system is currently recovering previous events, a subset of users in the US region may still be experiencing a delay in updating widgets in Live Dashboards. We will provide an update in 1h:30 minutes or sooner.
Posted Sep 02, 2025 - 18:57 UTC
Update
Mitigation steps have been applied, and the system is still recovering. The system is currently recovering previous events, a subset of users in the US region may still be experiencing a delay in updating widgets in Live Dashboards. We will provide an update in 45 minutes or sooner.
Posted Sep 02, 2025 - 17:58 UTC
Update
Mitigation steps have been applied, and the system is still recovering. The system is currently recovering previous events, a subset of users in the US region may still be experiencing a delay in updating widgets in Live Dashboards. We will provide an update in 30 minutes or sooner.
Posted Sep 02, 2025 - 17:29 UTC
Update
Mitigation steps have been applied, and the system is currently recovering. A subset of users in the US region may still be experiencing a delay in updating widgets in Live Dashboards. We will provide an update in 30 minutes or sooner.
Posted Sep 02, 2025 - 17:00 UTC
Update
Mitigation steps have been applied, and the system is currently recovering. A subset of users in the US region may still be experiencing a delay in updating widgets in Live Dashboards. We will provide an update in 30 minutes or sooner.
Posted Sep 02, 2025 - 16:25 UTC
Update
Mitigation steps are still in progress. Users in the US region may still be experiencing a delay in updating widgets in Live Dashboards. We will provide an update in 30 minutes or sooner.
Posted Sep 02, 2025 - 15:49 UTC
Update
Mitigation steps are still in progress. Users in the US region may still be experiencing a delay in updating widgets in Live Dashboards. We will provide an update in 15 minutes or sooner.
Posted Sep 02, 2025 - 15:33 UTC
Identified
Our engineering team has been engaged in the incident resolution, and mitigation measures are in progress. Users might experience a delay in updating widgets in Live Dashboards in the US region. We will provide an update in 15 minutes or sooner.
Posted Sep 02, 2025 - 15:19 UTC
Investigating
We are currently investigating reports of delays on updating widgets on Talkdesk Live Dashboard in our US region.
Posted Sep 02, 2025 - 15:08 UTC
This incident affected: US (mytalkdesk.com) (Talkdesk for Salesforce (Talkdesk Integrations), Talkdesk Zendesk Connector (Talkdesk Integrations), Talkdesk Live™ Dashboard (Talkdesk Platform), Talkdesk Explore™ Reporting (Talkdesk Platform), Talkdesk Copilot™ (Talkdesk Ascend AI)).