Call Performance Degradation

Incident Report for Talkdesk

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 17:54 UTC

Monitoring

Mitigation measures are currently in progress. We are observing internal recovery in our metrics. We will continue to monitor to ensure a smooth recovery.
Posted Jun 16, 2025 - 17:46 UTC

Investigating

We are observing degradation with call handling and inbound calls in US region since 17:00 UTC, causing errors when attempting to transfer calls, place them on hold, or when routing. We will provide an update as soon as we have more details.
Posted Jun 16, 2025 - 17:30 UTC
This incident affected: Americas (US) (Inbound Calls (Talkdesk Voice)).