Unable to login
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Jul 14, 2023 - 14:31 UTC
Monitoring
Mitigation measures were applied and we are currently seeing system recovery. We will keep monitoring and provide an update in 15 minutes.
Posted Jul 14, 2023 - 14:29 UTC
Update
We are currently applying mitigation measures in order to resolve the issue. Customers may still be experiencing degraded performance in Login and Voice functionalities. We will provide an update within 15 minutes.
Posted Jul 14, 2023 - 14:23 UTC
Update
We are currently experiencing an issue affecting Login and Voice functionalities in US regional deployment. Mitigation measures are currently in progress. We will provide an update within 15 minutes.
Posted Jul 14, 2023 - 14:19 UTC
Identified
We are currently experiencing an issue affecting Login and Voice functionalities in US regional deployment. Mitigation measures are currently in progress. We will provide an update within 15 minutes.
Posted Jul 14, 2023 - 14:12 UTC
Update
We are currently experiencing an issue affecting Login and Voice functionalities in US regional deployment. Mitigation measures are currently in progress. We will provide an update within 15 minutes.
Posted Jul 14, 2023 - 14:07 UTC
Investigating
We are currently experiencing an issue affecting Login in US regional deployment. We will provide an update within 15 minutes.
Posted Jul 14, 2023 - 13:50 UTC
This incident affected: Americas (US) (Inbound (Telephony), Outbound (Telephony), Talkdesk ID Login (Platform), Talkdesk Salesforce (Integrations), Talkdesk ServiceNow Connector (Integrations), Call Flows & Routing (Agent Experience & Routing)).