Service Degradation
Incident Report for Talkdesk
Resolved
The incident is Resolved, all systems are back to normal.
Posted Dec 15, 2021 - 16:21 UTC
Identified
We are observing system recovery. We will keep monitoring and provide an update in 15 min.
Posted Dec 15, 2021 - 16:09 UTC
Investigating
We are observing login degraded performance impacting a sub-set of Talkdesk customers in the US Region due to a service degradation of AWS. We will provide an update in 15 min.
Posted Dec 15, 2021 - 15:56 UTC
This incident affected: Platform (Talkdesk ID Login) and Apps (Callbar).