Unable to receive inbound calls
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 03, 2018 - 13:41 PDT
Monitoring
Our engineering team reports that a brief issue in our systems caused inbound routing difficulty for some customers. We have indications this has passed and are continuing to monitor our systems.
Posted 2 months ago. Oct 03, 2018 - 13:28 PDT
Investigating
We've received reports of customers unable to answer calls. We're investigating this and will provide an update here when we have more information.
Posted 2 months ago. Oct 03, 2018 - 13:16 PDT
This incident affected: Voice - Incoming Browser Calls.