Service Degradation
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Sep 08, 2022 - 21:54 UTC
Monitoring
Mitigation measures are currently in progress and we are seeing improvements. All critical functionality including making and receiving calls are back live. A subset of customers may still expect Agent Status Live latency. We will provide an update in the next hour.
Posted Sep 08, 2022 - 20:47 UTC
Update
Mitigation measures were applied and we are seeing improvements. All critical functionality including making and receiving calls are back live. The system is still consuming all the pending events, therefore the Agent Status in Live is currently changing however still experiencing latency, as well as Latency on Historical data. We will provide an update in the next hour.
Posted Sep 08, 2022 - 19:38 UTC
Update
Mitigation measures were applied and we are seeing improvements. All critical functionality including making and receiving calls are back live. Agent Status in Live is still experiencing latency, as well as degraded Historical data. We will provide an update in the next hour.
Posted Sep 08, 2022 - 18:21 UTC
Update
Mitigation measures were applied and we are seeing improvements. All critical functionality including making and receiving calls are back live. Agent Status in Live is still experiencing latency. We will provide an update in the next hour.
Posted Sep 08, 2022 - 18:03 UTC
Update
Mitigation measures are currently in progress and we are seeing improvements. All critical functionality including making and receiving calls are back live. A subset of customers is still experiencing Agent Status Live latency. We will provide an update in 30 minutes or sooner.
Posted Sep 08, 2022 - 17:26 UTC
Update
Mitigation measures are currently in progress and we are seeing improvements. All critical functionality including making and receiving calls are back live. Agent Status in Live is experiencing latency. We will provide an update in 30 minutes or sooner.
Posted Sep 08, 2022 - 17:07 UTC
Update
Mitigation measures are currently in progress and we are seeing improvements. All critical functionality including making and receiving calls are back live. Agent Status in Live is experiencing latency. We will provide an update in 15 minutes or sooner.
Posted Sep 08, 2022 - 16:51 UTC
Update
Mitigation measures are currently in progress and we are seeing improvements, a subset of users are experiencing degraded performance loading Talkdesk. We will provide an update in 15 minutes or sooner.
Posted Sep 08, 2022 - 16:45 UTC
Update
Mitigation measures are currently in progress and we are seeing improvements, a subset of users are experiencing degraded performance loading Talkdesk. We will provide an update in 15 minutes or sooner.
Posted Sep 08, 2022 - 16:34 UTC
Identified
We are currently investigating degraded performance loading Talkdesk. We will provide an update in 15 minutes or sooner.
Posted Sep 08, 2022 - 16:30 UTC
This incident affected: Reporting & Analytics (Live Reporting, Historical Reporting), Apps (Agent Workspace), and Agent Experience & Routing (Agent Dashboard, Call Controls).