Performance degradation in US region

Incident Report for Talkdesk

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 17:13 UTC

Monitoring

We have applied mitigation measures and we are seeing improvements. We post updates as soon as we confirm full recovery.
Posted Jun 12, 2025 - 17:02 UTC

Investigating

We are observing some degradation across multiple apps in the US region since 16:19 UTC, causing call errors. Based on our investigation, this issue is only impacting a subset of users. We will provide an update as soon as we have more details.
Posted Jun 12, 2025 - 16:52 UTC
This incident affected: Americas (US) (Inbound Calls (Talkdesk Voice)).