Intermittent Call Issues in Europe
Incident Report for Talkdesk
Resolved
All systems are back to normal
Posted Feb 03, 2016 - 19:49 UTC
Monitoring
Our telecom provider has been able to resolve the issues that affected their European datacenter. We'll continue to perform tests while monitoring our systems and customer feedback to ensure the problem has been completely resolved.
Posted Feb 03, 2016 - 16:17 UTC
Update
The European datacenter is still experiencing network connectivity issues and our telecom provider is still working to resolve it. We'll send out another update shortly.
Posted Feb 03, 2016 - 15:09 UTC
Update
Our telecom provider continues to work to resolve the situation. We'll provide another update shortly. But if you're facing these issues, please reach out to us at support@talkdesk.com so we can help.
Posted Feb 03, 2016 - 14:11 UTC
Update
Resolution to the issue is still being worked on by our telecom provider. We are working with affected European customers on a workaround until the situation is resolved. If you're being affected and haven't reached out, please do so by emailing support@talkdesk.com

We'll provide another update shortly.
Posted Feb 03, 2016 - 13:41 UTC
Update
Our telecom provider is still working on resolving the issue. Expect another update in the next 30 minutes.
Posted Feb 03, 2016 - 13:00 UTC
Update
Our telecom provider continues to work to resolve the situation in their European datacenter. We'll provide another update shortly.
Posted Feb 03, 2016 - 12:31 UTC
Identified
Our telecom provider is currently experiencing intermittent issues in initiating web browser based calls with their European datacenter and are currently underway in resolving the issue. This means some agents may experience an issue when trying to answer a call or making an outbound via the browser. Another update will be posted within 30 minutes.
Posted Feb 03, 2016 - 11:45 UTC