Latency Issues
Incident Report for Talkdesk
Resolved
Integrations and automations are now presenting normal performance and the system is now stable. This incident has been resolved.
Posted Aug 26, 2021 - 22:17 UTC
Monitoring
Live Dashboard is caught up and is displaying real-time data. We continue to monitor integrations and automations. We will continue to publish regular updates.
Posted Aug 26, 2021 - 20:27 UTC
Update
All users are able to log in to the application, make inbound and outbound calls. Due to the latency that was caused in the system, the Live reporting is catching up to all the calls and will be up to date in a few minutes. Similarly, integration and automation are also catching up and will take some time to update all the automations. However, no automation will be lost.
Posted Aug 26, 2021 - 19:49 UTC
Update
A mitigation measure has been applied to our assignment system. We expect to see improvements soon. We will provide further updates as soon as possible.
Posted Aug 26, 2021 - 19:23 UTC
Update
Login issues are now resolved. We are currently tackling the calls assignment backlog. We will provide further updates as soon as possible.
Posted Aug 26, 2021 - 18:36 UTC
Update
AWS latency issue is improving. We are observing some improvements for some of the impacted regions. We are validating and will provide further updates as soon as possible.
Posted Aug 26, 2021 - 18:12 UTC
Identified
We are seeing widespread latency in the system related to an ongoing AWS incident. Users may experience a 504 error when trying to log in. We are connecting with AWS and will provide further updates as soon as possible. Please know more here: https://status.aws.amazon.com/
Posted Aug 26, 2021 - 17:32 UTC
Investigating
We are investigating reports of system latency. We will provide an update as soon as we have more details.
Posted Aug 26, 2021 - 17:21 UTC
This incident affected: Reporting & Analytics (Live Reporting).