Application errors
Incident Report for Talkdesk
Resolved
Further monitoring has revealed no recurrence of the earlier issues affecting calls. This incident is now resolved.

If you need additional help, please reach out to us at support@talkdesk.com
Posted Jan 14, 2021 - 00:18 UTC
Update
We have seen full recovery from the earlier issues. We are continuing to monitor for any further issues.
Posted Jan 13, 2021 - 23:35 UTC
Monitoring
We have applied additional mitigating measures and have seen improvement from the earlier issues. We will continue to monitor the situation.
Posted Jan 13, 2021 - 23:24 UTC
Update
We are still continuously engaged in mitigating intermittent problems affecting calls.
Posted Jan 13, 2021 - 23:04 UTC
Update
We are continuing to work to mitigate this issue.
Posted Jan 13, 2021 - 22:13 UTC
Identified
We have identified an issue causing failures in a subset of calls. We are still working to mitigate the issue.
Posted Jan 13, 2021 - 21:44 UTC
Update
We are working to mitigate intermittent problems making and receiving calls.
Posted Jan 13, 2021 - 21:21 UTC
Update
We are still investigating intermittent problems making and receiving calls.
Posted Jan 13, 2021 - 21:04 UTC
Update
We are continuing to investigate reports of intermittent problems making and receiving calls.
Posted Jan 13, 2021 - 20:42 UTC
Investigating
We have received reports of application errors and are investigating.
Posted Jan 13, 2021 - 20:27 UTC
This incident affected: Telephony (Inbound, Outbound) and Agent Experience & Routing (Call Flows & Routing).