Scheduled Maintenance

Scheduled for Apr 18, 00:00 UTC  -  Apr 20, 00:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 13, 2026 - 14:18 UTC

Scheduled

We will be conducting a resilience upgrade to our metadata database in EU from 18th April until 20th April for Call Recordings and Voicemail Recordings. There will be no loss of recordings or metadata during this upgrade however operations over recordings might be delayed during this timeframe, but they will be queued and processed. All other services dependent on recordings: Integrations or Transcriptions will operate without impact as well.
Posted Apr 13, 2026 - 09:18 UTC
This scheduled maintenance affects: Europe (mytalkdesk.eu) (Talkdesk Call Recording™ (Talkdesk Workforce Engagement)).