We sill now simulate recovery of US Regional Cloud Site 2 and after rebalance our accounts between both US Sites
Posted Mar 15, 2026 - 10:18 UTC
Update
We will now SIMULATE that US Regional Cloud Site 2 is down and we will execute the runbook to fully failover to Site 1
Posted Mar 15, 2026 - 09:45 UTC
Update
Our team is initiating the fire drill we will start by doing a Site Rebalancing a subset of tenants will change their site affinity from Site 2 to Site 1
Posted Mar 15, 2026 - 09:21 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 15, 2026 - 08:00 UTC
Scheduled
Talkdesk will be conducting a scheduled fire drill of our regional failover tool in the US Region to ensure our disaster recovery runbooks are current and fully operational. During this period some users may receive a notification to restart their Workspace App; if prompted, please follow the instructions.