We will postpone this intervention. We will send a communication as soon as possible. We apologize for any inconvenience this may cause.
Posted Feb 15, 2025 - 19:15 UTC
Scheduled
Talkdesk will be performing a platform maintenance on Sunday, February 16th, 2025, between 08:00 UTC - 11:00 UTC (02:00 - 05:00 PDT).
During this time, we will be making infrastructure enhancements to improve platform resilience.
What to expect: During the maintenance window, customers might experience up to 15 minutes of reduced calling capabilities in EU deployment region, including: - Inability to complete mid-call operations (e.g. transfers). - New calls will not be processed by Studio Flows or routed to agents.
Ongoing calls that are active when the operation begins will remain unaffected.
We apologize for any inconvenience this may cause. We will keep this page updated with the latest information.
Thank you for your understanding.
Posted Feb 11, 2025 - 12:05 UTC
This scheduled maintenance affected: Europe (Germany) (Inbound Calls (Talkdesk Voice), Outbound Calls (Talkdesk Voice)).