Queued calls appearing stuck
Incident Report for Talkdesk
Resolved
This issue is solved and we're continuing to monitor the situation. You should now be able to use Talkdesk again normally.

If you are still experiencing problems please reach out to us at support@talkdesk.com and we will be happy to help.
Posted Feb 08, 2021 - 15:28 UTC
Update
We are continuing to investigate some remaining issues leading to some agent's status not updating automatically.
Posted Feb 08, 2021 - 15:05 UTC
Monitoring
We can now observe calls dequeuing correctly and our engineering team is monitoring it closely. Some users are reporting changes of status to ACW. Our engineering team continues that investigation.
Posted Feb 08, 2021 - 14:15 UTC
Investigating
We are currently investigating an issue impacting a small subset of calls not dequeuing
Posted Feb 08, 2021 - 13:57 UTC
This incident affected: Agent Experience & Routing (Call Flows & Routing) and Apps (Talkdesk Conversations Mobile App).