Degraded performance impacting Agent Dashboard
Incident Report for Talkdesk
Resolved
Talkdesk’s service has been fully restored and this incident is therefore resolved.
Posted Jan 12, 2021 - 15:30 UTC
Monitoring
We are observing improvements and we're continuing to monitor the situation.
Posted Jan 12, 2021 - 15:15 UTC
Identified
Agents may be unable to access the Contacts page within the Talkdesk web application and certain contact related functionality may be affected. We will provide additional updates as more information becomes available.
Posted Jan 12, 2021 - 15:04 UTC
This incident affected: Apps (Callbar, Talkdesk Conversations Mobile App).