Inbound and Outbound Degraded Performance
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Nov 04, 2024 - 18:58 UTC
Monitoring
At this point, the Inbound and Outbound performance issues have been resolved, and users should no longer be experiencing difficulties. We will continue to monitor the situation.
Posted Nov 04, 2024 - 18:53 UTC
Investigating
We are observing voice degradation in the US region since 06:20 UTC causing Inbound and Outbound failures. This issue impacts a subset of Talkdesk customers. We will provide an update as soon as we have more details.
Posted Nov 04, 2024 - 18:39 UTC
This incident affected: Americas (US) (Inbound Calls (Talkdesk Voice), Outbound Calls (Talkdesk Voice)).