Issues with receiving/making calls
Incident Report for Talkdesk
Resolved
Our systems are now fully operational and everything has recovered.

Please reach out to support@talkdesk.com if you see otherwise.
Posted 10 months ago. Nov 05, 2018 - 09:19 PST
Update
We are continuing to monitor for any further issues.
Posted 10 months ago. Nov 05, 2018 - 09:12 PST
Monitoring
We are seeing improvements across all systems and we will continue to monitor.
Posted 10 months ago. Nov 05, 2018 - 09:07 PST
Update
We are continuing to investigate this issue.
Posted 10 months ago. Nov 05, 2018 - 08:50 PST
Update
We are continuing to investigate this issue.
Posted 10 months ago. Nov 05, 2018 - 08:34 PST
Investigating
Our telecom provider has identified an issue and we're currently working closely with them on fixing this.

We'll provide more updates shortly.
Posted 10 months ago. Nov 05, 2018 - 08:29 PST
This incident affected: Voice - Incoming Browser Calls, Voice - Incoming SIP Calls, Voice - Incoming External Phone Calls, Voice - Outgoing Browser Calls, and Voice - Outgoing SIP Calls.