Webchats and SMS degraded performance

Incident Report for Talkdesk

Resolved

This incident has been resolved.
Posted Apr 17, 2025 - 22:22 UTC

Monitoring

Our partner has completed the mitigation measures, and they are seeing some recovery on their end. We are monitoring our systems to ensure a smooth recovery. We will provide an update in 15 minutes or sooner.
Posted Apr 17, 2025 - 22:09 UTC

Update

Our partner is still working on completing the mitigation measures. We will provide an update in 15 minutes or sooner
Posted Apr 17, 2025 - 21:58 UTC

Update

Our partner is still working to apply mitigation measures. We will provide an update in 15 minutes or sooner.
Posted Apr 17, 2025 - 21:42 UTC

Update

Our partner has identified the root cause and is now applying mitigation measures. We will provide an update in 15 minutes or sooner.
Posted Apr 17, 2025 - 21:26 UTC

Update

We are still working with our partner to recover the functionality. We will provide an update in 15 minutes or sooner.
Posted Apr 17, 2025 - 21:16 UTC

Update

We are still working with our partner to recover the functionality. We will provide an update in 15 minutes or sooner.
Posted Apr 17, 2025 - 21:12 UTC

Identified

Our engineering team is currently working with our partner on the incident resolution. Users are unable to send Webchats and SMS's in the US and EU regions. We will provide an update in 15 minutes or sooner.
Posted Apr 17, 2025 - 20:57 UTC

Investigating

We are observing degraded performance with Webchat and SMS in US and EU regions since 20:18 UTC, causing errors for users. We will provide an update as soon as we have more details.
Posted Apr 17, 2025 - 20:34 UTC
This incident affected: Americas (US) (Talkdesk SMS (Talkdesk Omnichannel Engagement), Talkdesk Chat (Talkdesk Omnichannel Engagement)), Americas (Canada) (Talkdesk SMS (Talkdesk Omnichannel Engagement), Talkdesk Chat (Talkdesk Omnichannel Engagement)), and Europe (Germany) (Talkdesk SMS (Talkdesk Omnichannel Engagement), Talkdesk Chat (Talkdesk Omnichannel Engagement)).