Workspace tabs degraded performance

Incident Report for Talkdesk

Resolved

This incident has been resolved.
Posted Mar 13, 2025 - 13:15 UTC

Monitoring

At this point, the issue has been fixed and customers should no longer be experiencing difficulties. We will continue to monitor the situation.
Posted Mar 13, 2025 - 13:10 UTC

Identified

Our engineering team has been engaged on the incident resolution, and mitigation measures are in progress. We will provide an update in 15 minutes or sooner.
Posted Mar 13, 2025 - 12:59 UTC

Investigating

We are observing some tabs in Workspace in the US, EU, and CA deployment region causing the tabs to not load. We will provide an update as soon as we have more details.
Posted Mar 13, 2025 - 12:45 UTC
This incident affected: Americas (US) (Talkdesk Workspace™ (Talkdesk Platform)) and Europe (Germany) (Talkdesk Workspace™ (Talkdesk Platform)).