Failures receiving calls to European countries.
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Mar 18, 2019 - 16:31 PDT
Update
This incident has been resolved.
Posted Mar 18, 2019 - 16:30 PDT
Update
We have been able to mitigate most of the impacted ranges of numbers affecting our customers.
We continue to work with our partners for a full resolution.
Posted Mar 18, 2019 - 15:20 PDT
Update
We have been able to mitigate most of the impacted ranges of numbers affecting our customers.
We continue to work with our partners for a full resolution.
Posted Mar 18, 2019 - 13:51 PDT
Monitoring
We have seen a recovery in some of the numbers affected, our partner carrier has mitigated the issue in one of their regions.

We keep working closely with our partners to achieve full resolution.
Posted Mar 18, 2019 - 12:58 PDT
Identified
Our partner carrier had network issues affecting two of their European points of presence
Posted Mar 18, 2019 - 12:54 PDT
Investigating
Investigating - We are observing failures receiving calls to some of the numbers in multiple European countries including Italy, Belgium, Germany, Portugal, Netherlands, Romania and Luxembourg. We are working with our carrier partner to resolve the issue. We will provide an update as soon as possible.
Posted Mar 18, 2019 - 11:44 PDT
This incident affected: Voice - Incoming Browser Calls.