Inbound Calls not Connecting
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Jun 24, 2021 - 15:33 UTC
Monitoring
At this point, the issue has been fixed and customers should no longer be experiencing difficulties. We will continue to monitor the results.
Posted Jun 24, 2021 - 15:16 UTC
Update
Mitigation steps are still in progress. We will provide an update in 15 minutes or sooner.
Posted Jun 24, 2021 - 15:05 UTC
Identified
Our engineering team has been engaged in incident resolution. Mitigation steps have been taken and recovery is in progress. We will provide an update in 15 minutes or sooner.
Posted Jun 24, 2021 - 14:44 UTC
Investigating
We are observing system degraded performance since 14:15 UTC causing Inbound calls not connecting. We will provide an update as soon as we have more details.
Posted Jun 24, 2021 - 14:24 UTC
This incident affected: Telephony (Inbound).