Workspace degraded performance
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Oct 03, 2024 - 19:20 UTC
Monitoring
We are currently seeing system recovery, Talkdesk engineering team is currently monitoring the system. We will send an update in 30 min or sooner.
Posted Oct 03, 2024 - 19:13 UTC
Identified
Mitigation measures are in progress, some customers might still get errors across Workspace Apps. We will share an update in 30 min or sooner.
Posted Oct 03, 2024 - 18:16 UTC
Update
The investigation is ongoing, and some customers might get errors across Workspace Apps. We will share an update in 30 min or sooner.
Posted Oct 03, 2024 - 17:58 UTC
Update
We are currently investigating reports of errors in Workspace Apps. We will share an update in 15 min or sooner.
Posted Oct 03, 2024 - 17:41 UTC
Investigating
We are currently investigating this issue.
Posted Oct 03, 2024 - 17:21 UTC
This incident affected: Americas (US) (Talkdesk Workspace™ (Products for Platform)).