Issues with log in
Incident Report for Talkdesk
Resolved
We experienced a brief period of instability with our login system. It has been resolved. Please contact support@talkdesk.com if you are continuing to experience any issues.
Posted about 2 months ago. Jun 26, 2019 - 12:03 PDT
Monitoring
We've seen broad recovery from the earlier issue affecting log-ins. We will continue to monitor.
Posted about 2 months ago. Jun 26, 2019 - 11:54 PDT
Update
We have observed improvement from an earlier problem that may have resulted in agents being logged out of Talkdesk and having difficulty logging back in. Affected customers are encouraged to refresh the application and try again. Our engineering team is continuing to investigate and monitor.
Posted about 2 months ago. Jun 26, 2019 - 11:49 PDT
Investigating
We have observed agents having difficulties logging in to our application. We are investigating and will update here shortly.
Posted about 2 months ago. Jun 26, 2019 - 11:43 PDT
This incident affected: Agent Dashboard and Talkdesk ID Login.