Issue affecting ring groups
Incident Report for Talkdesk
Resolved
The earlier incident has been resolved. If you need further assistance, please reach out to us at support@talkdesk.com
Posted Feb 23, 2021 - 20:45 UTC
Monitoring
We have now resolved the issue affecting ring groups loading and related functionality. You should now be able to use Talkdesk again normally, including the ability to transfer calls. We're continuing to monitor the situation.

If you are still experiencing problems, please reach out to us at support@talkdesk.com and we will be happy to help.
Posted Feb 23, 2021 - 19:55 UTC
Investigating
We are observing a problem right now affecting some customers' ability to load ring groups and perform transfers. Inbound and outbound calls should work normally. We are investigating the root cause. We will provide another update soon.
Posted Feb 23, 2021 - 19:31 UTC
This incident affected: Agent Experience & Routing (Call Controls) and Apps (Callbar).