At this point, the issue has been fixed, and customers should no longer be experiencing difficulties. We will continue to monitor the situation with the provider.
Posted Aug 21, 2025 - 18:39 UTC
Update
Our provider has been engaged on the incident resolution. We are seeing some recovery at this time. We will provide an update in 15 minutes or sooner.
Posted Aug 21, 2025 - 18:31 UTC
Identified
Our provider has been engaged on the incident resolution. We will provide an update in 15 minutes or sooner.
Posted Aug 21, 2025 - 18:21 UTC
Investigating
We are observing degraded performance with Explore in the US and EU regions, causing reports to appear blank due to an infrastructure provider. This issue impacts all users. We will provide an update as soon as we have more details.
Posted Aug 21, 2025 - 18:13 UTC
This incident affected: US (mytalkdesk.com) (Talkdesk Explore™ Reporting (Talkdesk Platform)), Canada (mytalkdeskca.com) (Talkdesk Explore™ Reporting (Talkdesk Platform)), and Europe (mytalkdesk.eu) (Talkdesk Explore™ Reporting (Talkdesk Platform)).