Inbound and Outbound PCI calls degraded performance

Incident Report for Talkdesk

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 18:53 UTC

Monitoring

A fix has been implemented by our voice service provider, and we are seeing recovery on our systems. Updates will be provided at the earliest opportunity.
Posted Apr 01, 2025 - 18:30 UTC

Update

We are working with our voice service provider on the incident resolution. Mitigation measures are in progress. We will provide an update as soon as possible.
Posted Apr 01, 2025 - 18:22 UTC

Identified

Mitigation measures are in progress, and we are seeing recovery in our systems. A subset of customers may experience some inbound/outbound call failures. Updates will be provided at the earliest opportunity.
Posted Apr 01, 2025 - 17:56 UTC

Monitoring

Mitigation measures are in progress, and we are seeing recovery in our systems. A subset of customers may experience some inbound/outbound call failures. Updates will be provided at the earliest opportunity.
Posted Apr 01, 2025 - 17:48 UTC

Identified

The Talkdesk voice service provider has been engaged in the incident resolution. Mitigation measures are in progress. We will provide an update as soon as possible.
Posted Apr 01, 2025 - 17:30 UTC
This incident affected: Americas (US) (Talkdesk Secure Payments™ (Talkdesk Platform)).