Service Degradation
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Dec 19, 2022 - 19:12 UTC
Update
Mitigation measures were put in place and we are seeing improvements. We will keep monitoring.
Posted Dec 19, 2022 - 19:11 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 19, 2022 - 19:07 UTC
Investigating
We are currently investigating degraded performance affecting the ability to Change Status. Mitigation Measures are in progress. We will provide an update in 15 minutes or sooner.
Posted Dec 19, 2022 - 18:59 UTC
This incident affected: Platform (Talkdesk ID Login).