Live dashboard and Integrations degraded performance in US region

Incident Report for Talkdesk

Resolved

This incident has been resolved.
Posted Sep 04, 2025 - 19:30 UTC

Monitoring

We are seeing full recovery across all affected services, including Live. We will continue to monitor this behavior to ensure a smooth recovery.
Posted Sep 04, 2025 - 18:34 UTC

Update

Mitigation measures were successful and we are seeing stability. We are still actively and closely monitoring and will update shortly.
Posted Sep 04, 2025 - 17:56 UTC

Update

Mitigation measures were applied and we are seeing improvements. We are still monitoring and we will update shortly.
Posted Sep 04, 2025 - 17:23 UTC

Identified

Mitigation measures are being applied. We are still seeing some lag on Live, Explore and Integrations. We will update shortly.
Posted Sep 04, 2025 - 16:57 UTC

Investigating

We are seeing increased lag on Live and Integrations. We are currently investigating, we will update shortly.
Posted Sep 04, 2025 - 16:41 UTC
This incident affected: US (mytalkdesk.com) (Talkdesk for Salesforce (Talkdesk Integrations), Talkdesk Zendesk Connector (Talkdesk Integrations), Talkdesk Slack Connector (Talkdesk Integrations), Talkdesk ServiceNow Connector (Talkdesk Integrations), Talkdesk Live™ Dashboard (Talkdesk Platform), Talkdesk Explore™ Reporting (Talkdesk Platform)).