Outbound and Inbound call failures in US region

Incident Report for Talkdesk

Resolved

This incident has been resolved.
Posted Sep 05, 2025 - 22:02 UTC

Update

Mitigation measures have been applied, and we are seeing recovery. We will continue to monitor to ensure stability.
Posted Sep 05, 2025 - 21:44 UTC

Update

Mitigation measures have been applied. We are still seeing recovery; calls are being delivered. While the system recovers, a subset of users may observe a delay in updating their status. We are continuing to monitor for improvements. We will provide an update in 15 minutes or sooner.
Posted Sep 05, 2025 - 21:34 UTC

Update

Mitigation measures have been applied, and we are seeing recovery, but while the system recovers, a subset of users may observe a delay in updating their status. We are continuing to monitor for improvements. We will provide an update in 15 minutes or sooner.
Posted Sep 05, 2025 - 21:18 UTC

Update

Mitigation measures have been applied. The system is still recovering; a subset of users may experience issues with Outbound and Inbound calls, as well as status changes when initiating calls. We are currently monitoring for improvements. We will provide an update in 15 minutes or sooner.
Posted Sep 05, 2025 - 20:56 UTC

Update

Mitigation measures have been applied. We are currently monitoring for improvements. We will provide an update in 15 minutes or sooner.
Posted Sep 05, 2025 - 20:40 UTC

Monitoring

Our engineering teams have applied mitigation measures in the form of a failover. Please refresh your instance to see improvements. We will provide an update in 15 minutes or sooner.
Posted Sep 05, 2025 - 20:26 UTC

Update

Our engineering teams are actively engaged and still applying mitigation measures. We are still seeing an impact on Inbound and Outbound calls in the US region. We will provide an update in 15 minutes or sooner.
Posted Sep 05, 2025 - 20:09 UTC

Identified

Our engineering teams are actively engaged and applying mitigation measures. We are still seeing an impact on Inbound and Outbound calls in the US region. We will provide an update in 15 minutes or sooner.
Posted Sep 05, 2025 - 19:54 UTC

Update

Our engineering team is actively engaged in the incident resolution. We are still observing degraded performance with Outbound and Inbound calls in the US region. To minimize impact, we suggest activating your business continuity settings. We will provide an update in 15 minutes or sooner.
Posted Sep 05, 2025 - 19:39 UTC

Update

Our engineering team has been engaged in the incident resolution. We are still observing degraded performance with Outbound and Inbound calls in the US region. We will provide an update in 15 minutes or sooner.
Posted Sep 05, 2025 - 19:24 UTC

Investigating

We are observing degraded performance with Outbound and Inbound calls in the US region. We will provide an update as soon as we have more details.
Posted Sep 05, 2025 - 19:10 UTC
This incident affected: US (mytalkdesk.com) (Inbound Calls (Talkdesk Voice), Outbound Calls (Talkdesk Voice)).