At this point, the system is back to normal values, and the customers should not be experiencing any degraded performance. Incident resolved.
Posted Mar 31, 2025 - 21:06 UTC
Update
We are still seeing recovery on our systems. A subset of customers may encounter timeout errors, component failures, or increased processing times within components, Autopilot, and Chat, resulting in the non-delivery of conversations to agents. Updates will be provided at the earliest opportunity.
Posted Mar 31, 2025 - 20:11 UTC
Update
A fix has been implemented by our voice service provider, and we are still seeing recovery on our systems. A subset of customers may encounter timeout errors, component failures, or increased processing times within components, Autopilot, and Chat, resulting in the non-delivery of conversations to agents. Updates will be provided at the earliest opportunity.
Posted Mar 31, 2025 - 19:55 UTC
Update
A fix has been implemented by our voice service provider, and we are still seeing recovery on our systems. A subset of customers may encounter timeout errors, component failures, or increased processing times within components, Autopilot, and Chat, resulting in the non-delivery of conversations to agents. Updates will be provided at the earliest opportunity.
Posted Mar 31, 2025 - 19:38 UTC
Update
A fix has been implemented by our voice service provider, and we are still seeing recovery on our systems. A subset of customers may encounter timeout errors, component failures, or increased processing times within components, Autopilot, and Chat, resulting in the non-delivery of conversations to agents. Updates will be provided at the earliest opportunity.
Posted Mar 31, 2025 - 19:18 UTC
Update
A fix has been implemented by our voice service provider, and we are still seeing recovery on our systems. A subset of customers may experience specific studio components, Autopilot and Chat, not delivering the conversation to the agent. We will update you as soon as possible
Posted Mar 31, 2025 - 18:42 UTC
Update
A fix has been implemented by our voice service provider, and we are still seeing recovery on our systems. Studio flows are currently recovering; a subset of customers may experience timeout errors, component failures, or longer time in components. We will update you as soon as possible
Posted Mar 31, 2025 - 18:04 UTC
Update
A fix has been implemented by our voice service provider, and we are still seeing recovery. We are currently monitoring our system.
Posted Mar 31, 2025 - 17:27 UTC
Monitoring
A fix has been implemented by our voice service provider, and we are currently seeing recovery. We will provide an update as soon as possible.
Posted Mar 31, 2025 - 17:10 UTC
Update
Mitigation measures are being applied, and we are currently seeing some recovery on our systems. We are following up with our voice service provider. Inbound and outbound calls are currently under degraded performance in the US and EU regions. We will provide an update as soon as possible.
Posted Mar 31, 2025 - 17:04 UTC
Update
Mitigation measures are still in progress, we are following up with our voice service provider. Inbound and outbound calls are currently under degraded performance in the US and EU regions. We will provide an update as soon as possible.
Posted Mar 31, 2025 - 16:48 UTC
Update
Mitigation measures are still in progress, we are following up with our voice service provider. Inbound and outbound calls are currently under degraded performance. We will provide an update as soon as possible.
Posted Mar 31, 2025 - 16:40 UTC
Update
Mitigation measures are still in progress, we are following up with our voice service provider. Inbound and outbound calls are currently under degraded performance. We will provide an update as soon as possible.
Posted Mar 31, 2025 - 16:39 UTC
Update
Mitigation measures are still in progress, we are following up with our voice service provider. We will provide an update as soon as possible.
Posted Mar 31, 2025 - 16:25 UTC
Identified
The Talkdesk voice service provider has been engaged in the incident resolution. Mitigation measures are in progress. We will provide an update as soon as possible.
Posted Mar 31, 2025 - 16:09 UTC
Update
Our engineering team has been engaged in the incident resolution. Mitigation measures are in progress. We will provide an update in 15 minutes or sooner.
Posted Mar 31, 2025 - 15:57 UTC
Investigating
We are observing a subset of inbound calls not connecting/dropping in the US region. We will provide an update as soon as we have more details.