Inbound and Outbound Degraded performance
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Oct 30, 2024 - 17:08 UTC
Monitoring
At this point, the issue has been fixed and customers should no longer be experiencing difficulties. We will continue to monitor the situation.
Posted Oct 30, 2024 - 17:00 UTC
Investigating
We are observing voice degradation in the US region causing Inbound and Outbound failures. This issue impacts a subset of Talkdesk customers. We will provide an update as soon as we have more details.
Posted Oct 30, 2024 - 16:56 UTC
This incident affected: Americas (US) (Inbound Calls (Talkdesk Voice), Outbound Calls (Talkdesk Voice)).