Localized Connection Issues in Australia
Incident Report for Talkdesk
Resolved
The issue has been mitigated for affected customers. We will continue to monitor the situation for the rest of the day. Please reach out to support@talkdesk.com if you experience any issue.
Posted 7 months ago. Apr 13, 2018 - 02:51 PDT
Identified
We have a workaround that has been put in place for the affected accounts in Australia. Please reach out to support@talkdesk.com if you experience issues in connecting to Talkdesk in Australia.
Posted 7 months ago. Apr 13, 2018 - 01:29 PDT
Investigating
We're currently investigating issues in logging into Talkdesk from areas in Australia such as Sydney, Brisbane, and Perth. We will update this ticket with more information as soon as we have it.
Posted 7 months ago. Apr 13, 2018 - 00:51 PDT