Small percentage of North American numbers not able to receive calls
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted 8 months ago. Mar 14, 2018 - 15:24 PDT
Monitoring
We are seeing a recovery of call activity to the North American numbers impacted by the carrier service degradation. We will continue to monitor. Please contact us at support@talkdesk.com if you are having any issues.
Posted 8 months ago. Mar 14, 2018 - 15:04 PDT
Identified
Currently a small percentage of Twilio North American phone numbers are not able to receive inbound calls. They are working with their carrier partner to resolve the issue. Please contact support@talkdesk.com if you are having any issues.
Posted 8 months ago. Mar 14, 2018 - 14:27 PDT