Inbound and Outbound calls Degraded performance
Incident Report for Talkdesk
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 16:59 UTC
Update
Mitigation measures are being applied by our carrier partner and at this point, we are seeing improvements in the success rate of inbound and outbound calls. We are continuously working with our partner in order to recover the service as quickly as possible. We will share more updates as soon as possible.
Posted Apr 22, 2024 - 16:27 UTC
Update
Mitigation measures are still in progress and we are continuously working with our partner in order to recover the service as quickly as possible. We will provide an update in 20 minutes or sooner.
Posted Apr 22, 2024 - 16:07 UTC
Update
Mitigation measures are in progress and we are continuously working with our partner in order to recover the service as quickly as possible. We will provide an update in 20 minutes or sooner.
Posted Apr 22, 2024 - 15:44 UTC
Update
Mitigation measures are in progress and we are continuously working with our partner in order to recover the service as quickly as possible. We will provide an update in 20 minutes or sooner.
Posted Apr 22, 2024 - 15:25 UTC
Identified
The issue was identified and mitigation measures are currently in progress. We will provide an update in 20 minutes or sooner.
Posted Apr 22, 2024 - 15:03 UTC
Investigating
We are currently experiencing degraded performance on Inbound and Outbound calls. Mitigation measures are currently in progress we will provide an update in 20 minutes or sooner.
Posted Apr 22, 2024 - 14:48 UTC
This incident affected: Americas (US) (Inbound (Telephony), Outbound (Telephony)).